Instalação
Os SDKs de Coleta da Legiti estão disponíveis através de gerenciadores de pacotes padrão para as seguintes linguagens suportadas:
1
pod 'Legiti', '~> 1.1.3'
2
3
// Você também deve adicionar o seguinte código no final do seu Podfile
4
post_install do |installer|
5
installer.pods_project.targets.each do |target|
6
target.build_configurations.each do |config|
7
config.build_settings['BUILD_LIBRARY_FOR_DISTRIBUTION'] = 'YES'
8
end
9
end
10
end
Copied!
1
// In grandle.build (Project)
2
...
3
allprojects {
4
repositories {
5
...
6
mavenCentral()
7
}
8
}
9
10
// In grandle.build (Module.app)
11
...
12
dependencies {
13
...
14
implementation 'com.legiti:legiti:[version]@aar', { transitive = true }
15
(e.g. 'com.legiti:legiti:[email protected]')
16
}
Copied!
  • React Native (via NPM)
1
npm install react-native-legiti
2
// OR
3
yarn add react-native-legiti
Copied!
  • Javascript (via tag <script> ou npm package)
1
npm install legiti
2
// OR
3
yarn add legiti
4
// OR
5
<script src="https://files.lgtcdn.net/legiti-js/v1/legiti.min.js" />
Copied!
Last modified 3mo ago
Copy link